Serveur domotique : ça tourne

Publié le par david

Et voilà, j'ai mis en place la machine qui va me servir de serveur domotique.

J'avais quelques anciens PCs qui traînaient dans mon garage, j'en ai profité pour faire un peu le ménage. D'ailleurs ça a été assez rapide :
  • le premier a fait fondre un fusible lorsque je l'ai mis sous tension : poubelle !
  • le deuxième a gelé en plein milieu d'une install de Windows XP ; au bout de plusieurs tentatives, j'ai dû me rendre à l'évidence, il n'y avait plus rien à en tirer non plus.
Ces deux machines étaient initialement destinées à faire un don à l'école maternelle des enfants, mais elles vont finir à la déchetterie du coup...

Me restait une dernière machine, et heureusement cette fois c'est bon, elle a l'air de tenir le coup.
Ce n'est pas une machine de guerre (Celeron 2GHz, DD 40 Go et 500Mo de RAM), mais ça devrait suffire. Je vais quand-même tenter de récupérer la RAM et les disques durs des deux machines mentionnées ci-dessus, histoire de gonfler un peu la bête au cas où.

Elle tourne maintenant depuis 24 heures à son emplacement définitif, et pour l'instant elle est toujours debout, donc a priori elle a l'air bonne pour le service, même dans les conditions "extrêmes" qu'on a actuellement. En effet, elle a trouvé sa place dans le garage, et bien qu'il soit isolé, la température ambiante flotte autour de 0°C en ce moment. Ce qui est rassurant c'est que ça pourra difficilement être pire : vendredi dernier on s'est tapé un petit -16°C dehors, et c'est descendu au pire à -1°C dans le garage, donc sur le long terme, ça devrait le faire .

Au niveau système, j'ai installé dessus la dernière Ubuntu en date (la 9.10, Karmic Koala pour les intimes). Il y avait un moment que je n'avais pas installé de Linux, et j'ai été impressionné par la facilité de la chose. En plus la communauté qui existe autour de cette distribution est très active, ce qui permet d'avoir beaucoup d'infos pour résoudre les petits problèmes de config.

Venons-en aux problèmes justement
En fait il n'y en a eut qu'un. Comme je le disais, j'ai fait le choix de mettre la machine dans le garage, car comme elle est destinée à tourner en permanence et qu'elle fait du bruit (c'est une bonne vieille tour avec l'alim ronflante et les ventilos qui vont bien), ce n'était juste pas envisageable de la laisser dans mon salon. Et là, quid du réseau ? Il était évidement hors de question d'aller se geler par 0°C pour aller faire mumuse avec la bête, d'autant plus que pour l'instant, je n'ai même pas d'espace de travail digne de ce nom où je pourrais mettre un écran et un clavier (c'est bien d'avoir un grand garage, mais qu'est-ce qu'on entasse ! ).
Heureusement j'avais investi dans une carte PCI Wifi, un jour où j'en avais marre de tirer des câbles. Dans ce cas précis, ça aurait nécessité de percer le mur de la maison pour faire passer le fil, et tant que la config n'est pas bien stabilisée, je ne le sentais pas trop. J'y viendrais peut-être si j'ai des problèmes de débit, mais chaque chose en son temps.
Le Wifi donc : c'est là que ça a été un peu complexe à mettre en place (pas de drivers Linux natifs pour la carte, tentative infructueuse de configurer le Wifi alors que la carte Ethernet est activée...). Mais bon, au final ça fonctionne !
J'ai donc pu poser la machine à sa place, avec pour toute connectique juste l'alimentation
Comme il y a le mur de la maison, je n'ai qu'une qualité de signal moyenne (entre 40 et 50%), mais comme je le disais, on verra bien à l'usage si c'est suffisant ou s'il y a besoin de plus.

Je vais pouvoir commencer à la configurer tranquillement en SSH depuis le canapé du salon !
Pour finir, une petite photo du bestiau (de qualité médiocre, désolé... les photos avec l'iPhone, j'en reviens...)
ubuntusmall.jpg
L'est-y pas beau le p'tit pépère ?

Publié dans Hardware

Pour être informé des derniers articles, inscrivez vous :

Commenter cet article